• Официальной группы в Телеграм у нашего форума нет, все группы использующие в своем названии имя нашего форума являются мошенническими и администрация форума за деятельность таких групп ответственности не несет!

OC v3.х Какую версию OpenCart 3 ставить?

Radical

Разрушитель (V)
Сообщения
309
Симпатии
113
Баллы
13 330
Ребята, подскажите из матерых! На какой версии собирать магазин? Чтоб все плагины можно было без проблем найти, чтоб я с гемором не столкнулся в последствии! Если я поставлю последнюю официальную 3.0.3.7 - будут ли у меня проблемы с плагинами?
Буду крайне благодарен за совет специалиста.
 

CAPAXA

Команда форума
Разрушитель (V)
Сообщения
297
Симпатии
341
Баллы
8 649
Ребята, подскажите из матерых! На какой версии собирать магазин? Чтоб все плагины можно было без проблем найти, чтоб я с гемором не столкнулся в последствии! Если я поставлю последнюю официальную 3.0.3.7 - будут ли у меня проблемы с плагинами?
Буду крайне благодарен за совет специалиста.
Самая правильная версия 3.* это 2.3.*
 

CAPAXA

Команда форума
Разрушитель (V)
Сообщения
297
Симпатии
341
Баллы
8 649
Почему? Что с 3 версией и почему 2.3 выигрывает?
Потому что 3 - это тупиковая ветвь эволюции опенкарта.
Никаких существенных преимуществ перед 2,3 тройка не имеет.
А выиграш у 2.3 существенный. бОльшее количество модулей и шаблонов. И нет никому не нужного твига.

Но это лишь мое субъективное мнение.
 

jexve

Создатель (I)
Сообщения
2
Симпатии
2
Баллы
4
Согласен сам собирал и собираю не первый магазин версия 2.3 как по мне самая оптимальная и модули к ней легко найти по сравнению с 3
 

xjfg

Разрушитель (V)
Сообщения
29
Симпатии
23
Баллы
500
ой, когда то говорили и о 2.3 что это тупик и ничего хорошего не получится с этой версии, но прошло время и мнения поменялись.
3-я версия это просто эволюция опенкарт, не важно правильная или неправильная, но эволюция и от этого никуда не деться.
Плюс не забываем о версиях пхп.... настанет время и 2.3 станет совсем неактуальным, точто так же как и 3ка и последующие версии.
Если мы хотим получить правильный продающий магазин, нужно идти в ногу со временем и стараться поддерживать свежие версии и тенденции, так как в новых версиях можно встретить код с новыми требованиями ПС.
Ну а какую версию ставить? Так просто стабильную ставим и радуемся работе магаза и жизни.
 

CAPAXA

Команда форума
Разрушитель (V)
Сообщения
297
Симпатии
341
Баллы
8 649
ой, когда то говорили и о 2.3 что это тупик и ничего хорошего не получится с этой версии, но прошло время и мнения поменялись.
3-я версия это просто эволюция опенкарт, не важно правильная или неправильная, но эволюция и от этого никуда не деться.
Плюс не забываем о версиях пхп.... настанет время и 2.3 станет совсем неактуальным, точто так же как и 3ка и последующие версии.
Если мы хотим получить правильный продающий магазин, нужно идти в ногу со временем и стараться поддерживать свежие версии и тенденции, так как в новых версиях можно встретить код с новыми требованиями ПС.
Ну а какую версию ставить? Так просто стабильную ставим и радуемся работе магаза и жизни.
В том то и дело, что 3 - тупиковая ветвь. И Дениэль развивать 3,* и не собирается. Он уже пилит 4,0! И я вам открою военную тайну (на самом деле нет). Но только с самой последней версии опенкарта он поддерживает минимум 7,2. Все предудущие версии работают даже на 5,3!!!
И какие функциональные отличия 3.0 от 2.3? А их практически нет!
 

xjfg

Разрушитель (V)
Сообщения
29
Симпатии
23
Баллы
500
В том то и дело, что 3 - тупиковая ветвь. И Дениэль развивать 3,* и не собирается. Он уже пилит 4,0! И я вам открою военную тайну (на самом деле нет). Но только с самой последней версии опенкарта он поддерживает минимум 7,2. Все предудущие версии работают даже на 5,3!!!
И какие функциональные отличия 3.0 от 2.3? А их практически нет!
о версии 4 спорить не буду, и там таки да, минимум 7.2, а по поводу функциональных отличий.... так для меня что 1.5 что 2.3 что 3.0 не имеют особых функциональных отличий, всё решается доп модулями. я сначала вообще плевался на твиг, а ща ниче.... попривык
 

val06

Продвинутый (IV)
Сообщения
35
Симпатии
15
Баллы
235
у тройки судьба такая же как у 2.0, тупиковая заброшенная версия, тормоза и глюки.
По опыту скажу, что многие которые гнались за "в ногу со временем" через некоторое время уходили на 2.3, ну а другие, как в том анекдоте, ежики плакали и стонали, но продолжали тр..ть кактус )
Считаю самой лучшей версией 2.3 ПРО, ставлю только ее.
всё решается доп модулями
полностью не согласен.
 

innerjoin86

Разрушитель (V)
Сообщения
66
Симпатии
61
Баллы
283
о версии 4 спорить не буду, и там таки да, минимум 7.2, ...
Официального релиза OC 4.x пока нет, но то , что в текущей ветке разработке на GitHub (upload/index.php)
PHP:
// Version
define('VERSION', '4.0.0.0_b');
требует php не ниже 8
Из upload/system/startup.php на GitHub
PHP:
// Check Version
if (version_compare(phpversion(), '8.0.0', '<')) {
    exit('PHP8+ Required');
}
 
Последнее редактирование:

mr.teray

Созидатель (II)
Сообщения
6
Симпатии
10
Баллы
29
как бывалый скажу, нужен адекватный магазин с стабильным и хорошим функционалом, то 2.3.. сделал и зарабатываешь...
если тестер, кодер, извращуга который будет радовать своих клиентов ошибками, багами и приколами развираясь в новой 4.0 на перспективу тоже хорошая идея))
я так с 2.0 начинал в итоге у меня столько всего сделано, что я на 2.1 остался.. и переходить буду в скором времени сразу на 4 версию. перетаскивая все на новый движек
а вот 3 версия ни туда ни сюда... как сказали выше тупиковая...
 
  • Мне нравится
Симпатии: Denzy

val06

Продвинутый (IV)
Сообщения
35
Симпатии
15
Баллы
235
и переходить буду в скором времени сразу на 4 версию.
ну с 4 версией тоже пока не все так однозначно. куча багов и пока ее доработаю, если доработают, до нормального состояния думаю пойдет не меньше года, ла и потом пока на нее появятся нормальные шаблоны, нужные модули, пройдет не один день ))
да и тоже пока под большим вопросом, будет она доделана до нормального состояния или как )))
 

mr.teray

Созидатель (II)
Сообщения
6
Симпатии
10
Баллы
29
ну как сказать.... шаблоны меня никогда не интересуют... где индивидуальность?
а модули не проблема перебрать и старые ... а чего нету самому сделать..
 
  • Мне нравится
Симпатии: Denzy

val06

Продвинутый (IV)
Сообщения
35
Симпатии
15
Баллы
235
модули не проблема перебрать и старые
а вот это так просто вряд ли получится ))
насколько я знаю, там нет ни ocmod, ни vqmod, интеграция модулей происходит совершенно по другому принципу, честно скажу пока конкретно не копал, нет время на это.
 

maxx2205

Разрушитель (V)
Сообщения
30
Симпатии
46
Баллы
99
Мое личное мнение, ставить сейчас 2.3 можно, но не нужно :). Да, модулей и шаблонов под него очень много хороших и разных, и даже много где бесплатных :), но:
Опенкарт Про крайний походу стал последним :( и допиливается как-то в глубинах гитхаба лишь одним, хоть и неплохим кодером, которому, впрочем, интересней клепать модули под него на продажу, впрочем, осудить его за это нельзя :). Поэтому тупик :(, и все его глюки остаются с нами, ну или пишите с него свой форк :). Да и шаблоны на него допиливать еще та радость.
То что сделали с окстором 2.3 на профильном форуме, добавили сомнительных свистоперделок и одной строчкой кода перевели его на пхп 7 онли. И сказали, что и так замечательно будет. Так что также дописывайте сами-сами.
Про оригинальный опенкарт и русскую сборку ветки 2.3 не вспомнит уже и никто.
Что до третьей ветки, то мне лично нравится окстор 3.0.2. Его начали делать относительно вменяемые люди, и без дела кто попало туда руки не совал вроде. Особых глюков не заметил, субъективно работает быстрее и ровнее, чем 2.3, без кэшеров всяких под кубиком. Модулей и шаблонов всяких также завались :).
Еще копаюсь в русской сборке опенкарта 3.0.3.7. Там все с модулями и шаблонами сложнее, мало чего рабочего сразу есть, многое приходится допиливать. Однако на пхп 7.3 работает довольно резво, и, что удивительно - лог ошибок на настроенном магазе уже длительный период времени пустой, что я вообще очень редко вижу на оксторах.
И вообще, делайте на чем удобно и привыкли, ибо переезд с версии на версию на боевом шопе - еще тот гимор :).
 

val06

Продвинутый (IV)
Сообщения
35
Симпатии
15
Баллы
235
субъективно работает быстрее и ровнее, чем 2.3
честно скажу, не знаю, что и где у вас работает быстрее и ровнее, но только за последние полгода я перенес с окстор 3.0.2 4 человек на 2.3 про. люди просто заманались от постоянных тормозов, особенно в админке.
 

maxx2205

Разрушитель (V)
Сообщения
30
Симпатии
46
Баллы
99
Ну первое знакоство с окстором 3.0.2 и мне радости не принесло, но потом както подразобрался. На некоторых хостингах админка тройки принудительно дико кешируется в бразере и поэтому адские глюки. Поправляется размещением в папке админ хтаксеса с запретом кеширования. Я сегодня выложил сборку 3037, там это есть, оно же работает и на 3020. А насчет опенкарт про я уже написал, сам на нем делал, когда он еще ocshop назывался, начиная с 1.5.6 версии. В крайнюю 2.3 много напихали типа кривых стикеров, преимуществ товара и т.п. оно и не нужно часто, и корчуется не на раз два :). 2.1 ровнее была. Да и шаблоны адаптировать надо.
 
Верх